What are the requirements for the iPhone app?

by Camella Tierney - 9 Secs Read

Compatible with iPhone 3GS, iPhone 4, iPhone 4S, iPhone 5, iPod touch (3rd generation), iPod touch (4th generation), iPod touch (5th generation) and iPad. Requires iOS 6.0 or later. This app is optimized for iPhone 5.

 

Interested? Get started completely free.

Try it Now